About the 2 macs and 1 linux on a LAN

Mitchell Patenaude mrp at sonic.net
Fri Jul 21 21:04:44 PDT 2000

On Wed, Jul 19, 2000 at 11:11:32AM -0700, Mitchell Patenaude wrote:
> P.S.  I haven't been following this in detail, but what I have gathered
> is that you are trying to get a DEC tulip based NIC to be recognized 
> under RedHat.  The module loads, but doesn't ever work.  NIC works fine
> under DOS.  Is that a fair summary?

I went over to John's place after work last night. Here's what I found:

Hard coding the IRQ in the conf.modules wasn't a good idea, so I removed
that, and the module would load properly, and we got link light, etc.
However, he's still not getting ping from the other machines on his
home network.

We verfied the cable/network port by swapping cables with working machine.
So it's definately something about the card.

The best clues I could find were:

The lights on the LinkSys router showed that we had link, but it also
showed 10 rather than 100, (the 100 light wasn't lit like it was for
the two macs he had connected.)

When I did a flood ping, a very few packets would get through.  There were
about 5% showing up as errors, 1-2% showing up okay (though with ping
times ranging from 2ms up to 47seconds (47000 ms).

Tcpdump showed that arp was working, but only sporadically.

tcpdump didn't find the echo_request packets from the other machines on
the network.

I got the tulip_diag and mii_diag programs, and they showed that the card
thought it was running in MII 100 with full duplex.  (Interesting that
the router didn't show the 100 light). I thought that the FD might be
the problem, so I hard coded it to half duplex using the options=13 line
in the /etc/conf.modules, but that didn't help, and may have hurt.

I'm thinking it's probably an inabililty of the kingston (tulip) card
to handshake properly with the router.  I would suspect a bad cable,
but when we pulled it out from the back of the linux box and plugged it
into his mac it worked fine.  When we plugged the cable from the working
mac into the tulip card, it failed on the linux box, so the trouble is
definately in the case.  I would suspect that the card itself it bad,
but John says it was working fine at the install fest a few weeks back.

Does anybody else have any things to try that we haven't already?

  -- Mitch

More information about the talk mailing list