[NBLUG/talk] XFree86 4.3 -- I'm trapped in an upgrade vortex!

Dave Sisley dsisley at arczip.com
Sat Sep 6 08:52:02 PDT 2003


I'm lost in an upgrade vortex (I'd call it a spiral, but its beginning
suck!).  I won't bore you all with the chain of upgrades and tweaks, 
but I must say this is Linux's most frustrating 'feature'.

I'd also like to thank the guys on the IRC channel for all the help.
The nblug channel is a great tool - it's a great way to get some quick

Now for my current problem:

I am trying to upgrade to XFree86 4.3.  It seems to have installed ok,
but I had a few hiccups.  I'm running RH8 with a new 2.4.20-20.8

Right now, when I boot, it catches right after X starts up.  I 
call it the "Blue Screen of Wristwatch", or BSOW.  Just like it sounds, 
I get the light blue screen with the wristwatch.  The next thing I'm
supposed to see is the graphical login screen, but it never shows up.

I've been googling, and have tried the following:
If I ctrl-alt-f1, I can go to a command line.  I can log in as root,
run 'init 3' and then 'startx'.  I can get X running this way, but I
don't like it.

Someone suggested to someone with the same problem that perhaps they
hadn't removed all of the previous X install.  If I run 'rpm -qa | grep
XFree86', I get a list of packages for the 4.2.1 version.  If I try to
run 'rpm -e XFree86', I get a message listing a dozen things that
depend on the package and it doesn't remove the package.

Is there something I can do?  Is it a problem with the way X
autostarts?  the XF86 configuration file?

I appreciate any help you guys have!


More information about the talk mailing list