[NBLUG/talk] XFree86 4.3

Rob Orsini orsini at sonic.net
Fri Sep 12 12:54:00 PDT 2003

At 10:28 PM 9/11/2003 -0700, you wrote:
>On Thursday, September 11, 2003, at 03:28 PM, Kyle Rankin wrote:
>>On Thu, Sep 11, 2003 at 03:21:37PM -0700, Rob Orsini wrote:
>>>At 03:14 PM 9/11/2003 -0700, you wrote:
>>>>At 11:00 AM 9/11/2003 -0700, you wrote:
>>>>>On Thu, Sep 11, 2003 at 10:54:16AM -0700, Rob Orsini wrote:
>>>>>>Being a new Debian user with a ATI Radeon Mobility card on my Fujitsu
>>>>>>p2120, I'm looking for the most idiot proof method of upgrading xfree86
>>>>>>from 4.1 to 4.3 so that it can 'see' my card.  (I'm trying to avoid the
>>>>>>aforementioned "XFree86 upgrade Vortex")  I expect to be pointed to the
>>>>>>xfree86 instructions but am wondering if there are other options for
>>>>>There are experimental X 4.3 packages available for Debian, simply add
>>>>>line to your /etc/apt/sources.list:
>>>>>deb http://penguinppc.org/~daniels/sid/i386 ./
>>>>>and then apt-get update and apt-get upgrade
>>>>>By the way, you can search for experimental or other sources that aren't
>>>>>the standard Debian repositories by going to http://www.apt-get.org
>>>>>Kyle Rankin
>>>>So, I'm connected remotely to my P at the moment and have run the above
>>>>commands.  I might need to restart the box to get the 4.3 stuff to take
>>>>(??) but I'm pretty sure I won't be able to get back in till I get home
>>>>because my default net settings are hosed.  All that being said, I ran
>>>>`startx` and below is the tail end of the output. I'm don't know much
>>>>about what's going on except it looks promising that radeon_drv.o is
>>>>loading (of atempting to).  Any thoughts?  Oh, here's my conf file:
>>>Wait a minute!  The lid on on the laptop is closed.  Does that mean that I
>>>wouldn't have a chance a starting X from here?  lol
>>Honestly, it would be better to diagnose X problems when are you actually
>>physically at the machine.
>>By the way, you don't need to restart a machine to try a new X server you
>>have upgraded.  In Linux about the only time you would normally have to
>>reboot would be if you upgraded kernels and wanted to try the new one,
>>otherwise you can restart basically everything else without resorting to
>Alright, it's been a long night.  Here's what I've done.  Updated from 
>Woody to Sid (unstable).  Tried to re-update the 4.3 deb stuff which 
>wasn't working.  In an blind attempt to 'remove' those packages I ended up 
>hosing my install (perhaps).  Anyway, reinstalled Debian Woody.
>Again, upgraded to Sid.  Installed 4.3 stuff from said source and... 
>nuttin'.  Same XFree86 version and naturally same X errors.  I'm out of 
>ideas.  Can anyone offer some more direction?

Vortex Update: I found this Debian-XFree86 4.3 Howto: 
http://www.tuxmobil.org/debian_xfree43.html. Looks promising.


More information about the talk mailing list