[NBLUG/talk] apt == dangerous

William Tracy afishionado at gmail.com
Sat Apr 22 20:00:31 PDT 2006

I think I managed to update something without updating something else
that needed to be upgraded at the same time? At any rate, X wouldn't
start. As far as I could tell, everything else was working (so, yes, I
*could* have still moved my homework to another machine, but where's
the fun in that?).

I ran aptitude after it borked, and it wanted to uninstall a bunch of
stuff (including almost all of KDE!), so I forced it to reinstall
everything. I don't know the details of what aptitude does for
calculating dependencies, but I may have done the equivalent of
apt-get dist-upgrade *then*.

When that didn't make X work, I checked X's log files and discovered
that it couldn't find the default fonts. The error message mentioned
x-server-common, which wasn't installed, so I installed that then, and
all seems to be well now. <fingers crossed>

I do know that when I tried switching from stable to unstable (a month
or so ago--you can dredge up my story from the archives), I first ran
apt-get upgrade, and that killed a driver I needed. I ran apt-get
dist-upgrade, and that fixed the problem (but killed X...).

Why is it that I always seem to kill X? Seriously, the very first time
I tried installing Linux (from a freebie Mandrake CD) it took me
forever to get X working. Then, when I bought SuSE to try Linux "for
real", I tried to install the NVidia drivers, and killed X so bad it
took me a month to fix it... (Yay noob-ness!)

I've killed X so bad by screwing up the NVidia drivers that I
completely hung Linux once (I think I was trying to get the Xorg
composite extensions to work, at the time). I couldn't even switch
terminals, and was stuck staring at a stupid ncurses message until I
cold booted the machine.

Do I get a prize for that? ;-)


More information about the talk mailing list