[NBLUG/talk] Problems with netboot on Fedora Core 6, Kernel 2.6.20

Jeff Coffler jeff-list-nblug_talk at taltos.com
Sun Apr 15 18:14:23 PDT 2007

Hi folks,

I thought I'd post here before trying to find some relevant Fedora-specific mailing lists. This is such a specific problem, I'm not even certain where to go to for Fedora-specific mailing lists! :-(

I successfully have a Myth frontend doing a diskless netboot on kernel 2.6.19-1.2911.  The MythTV wiki pages - in particular, page:

was instrumental in getting this working.  I've been netbooting (diskless) successfully for months.

Well, I'm now trying to get kernel 2.6.20 to fly with netboot, and I'm having a heck of a time.  I've tried two kernels: 2.6.20-1.2933 and 2.6.20-1.2944. Problems are identical with both of those.

The problem: The disklessrc boot script isn't properly mounting the snapshot file system (near as I can tell) in a Read/Write fashion.

I've added some debugging / diagnostics to the script, and I believe I understand the problem better, but not how to solve it.

The first problem: the /.snapshot file system appears to be mounted RO, not RW (yes, the snapshot file system is exported from the server RW).  The MythTV wiki discussed it getting mounted RO, but I think it's not working).  The "normal" mount in the disklessrc fails:

    mount -t nfs $NFS_IP:${NFS_DIR}/snapshot /.snapshot -o rw,nolock

This fails because the / file system is mounted read-only, and I can't write to the mtab file.  So, I added a -n to the mount statement.

After this change, the mount doesn't show up in "df", but it is listed in /proc/mounts - but RO.

If I remount the file system as per the wiki for MythTV:

    mount -o remount,rw /.snapshot

This appears to fail as well (it complains that /.snapshot isn't in the /etc/fstab or /etc/mtab files; I tried adding to /etc/fstab, but I don't believe that file is looked at this early in the boot sequence).

Bottom line: The /.snapshot area is NOT mounted properly, and I can't get the system to come up.

If I export the root file system on the server as RW rather than RO, then the system comes up fine.  But having a separate root area per client is sort of pointless from an ease-of-maintenance perspective.  
I'd really like to get the snapshots working again.

I've googled, but not found anything relevant.

This is all done via the disklessrc file, using a kernel configured via system-config-netboot on Fedora.  This worked splendidly on Kernel 2.6.19, but is broken on 2.6.20.  Note that disklessrc (the script itself) is identical between these two kernel versions.

Anybody have any ideas?


    -- Jeff

More information about the talk mailing list