[NBLUG/talk] XFree86 4.3 -- I'm trapped in an upgrade vortex!

Mark Street jet at sonic.net
Sat Sep 6 10:51:02 PDT 2003

Sounds like you are up shit creek without a paddle......  Was the UPgrade to 
XFree86 4.3 an RPM package upgrade or a source code upgrade?  IF it was 
source you might need to back out of the RPM's that Red Hat installs first 
and configure X yourself... (a learning experience).... all the files don't 
go into the same place unfortunately.  Red Hat does some tricks of its own.

Sounds like you have all kinds of XFree files from many different sources.... 
back out, clean up and go from there... or go back to 4.2.1

Since you are booting into runlevel 5 (GUI login)....
*Did you check to see if gdm or kdm or xdm is installed?

Check out /etc/X11/prefdm and see how the display manager is called.  Heck 
that may be the only problem.. not having a display manager.

rpm -qi gdm
Name        : gdm                          Relocations: (not relocateable)
Version     :                           Vendor: Red Hat, Inc.
Release     : 5                             Build Date: Mon 24 Feb 2003 
02:43:52 PM PST
Install Date: Wed 20 Aug 2003 03:37:22 PM PDT      Build Host: 
Group       : User Interface/X              Source RPM: gdm-
Size        : 4057884                          License: LGPL/GPL
Signature   : DSA/SHA1, Mon 24 Feb 2003 04:44:31 PM PST, Key ID 
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : ftp://ftp.gnome.org/pub/GNOME/sources/gdm/
Summary     : The GNOME Display Manager.
Description :
Gdm (the GNOME Display Manager) is a highly configurable
reimplementation of xdm, the X Display Manager. Gdm allows you to log
into your system with the X Window System running and supports running
several different X sessions on your local machine at the same time.

On Saturday 06 September 2003 08:53, Dave Sisley wrote:
> Hey.
> I'm lost in an upgrade vortex (I'd call it a spiral, but its beginning
> suck!).  I won't bore you all with the chain of upgrades and tweaks,
> but I must say this is Linux's most frustrating 'feature'.
> I'd also like to thank the guys on the IRC channel for all the help.
> The nblug channel is a great tool - it's a great way to get some quick
> help.
> Now for my current problem:
> I am trying to upgrade to XFree86 4.3.  It seems to have installed ok,
> but I had a few hiccups.  I'm running RH8 with a new 2.4.20-20.8
> kernel.
> Right now, when I boot, it catches right after X starts up.  I
> call it the "Blue Screen of Wristwatch", or BSOW.  Just like it sounds,
> I get the light blue screen with the wristwatch.  The next thing I'm
> supposed to see is the graphical login screen, but it never shows up.
> I've been googling, and have tried the following:
> If I ctrl-alt-f1, I can go to a command line.  I can log in as root,
> run 'init 3' and then 'startx'.  I can get X running this way, but I
> don't like it.
> Someone suggested to someone with the same problem that perhaps they
> hadn't removed all of the previous X install.  If I run 'rpm -qa | grep
> XFree86', I get a list of packages for the 4.2.1 version.  If I try to
> run 'rpm -e XFree86', I get a message listing a dozen things that
> depend on the package and it doesn't remove the package.
> Is there something I can do?  Is it a problem with the way X
> autostarts?  the XF86 configuration file?
> I appreciate any help you guys have!
> -dave.
> _______________________________________________
> talk mailing list
> talk at nblug.org
> http://nblug.org/mailman/listinfo/talk

Mark Street, D.C.
Red Hat Certified Engineer
Cert# 807302251406074
Key fingerprint = 3949 39E4 6317 7C3C 023E  2B1F 6FB3 06E7 D109 56C0
GPG key http://www.streetchiro.com/pubkey.asc

More information about the talk mailing list